
Page 1RS2 32 Dow nload using  Configu ration Files 07/24/03

Shortridge Instruments, Inc.
7855 E. Redfield Road
Scottsdale, AZ 85260
(480) 991-6744 • Fax: (480) 443-1267
www.shortridge.com

GET A QUICK START USING THE WINWEDGE™ CONFIGURATION FILES

WinWedge from TAL Technologies, Inc., collects data from scales and balances, gauges,
laboratory instruments, meters, sensors or any other RS232 instrument or serial device and inputs
the data directly into Microsoft Excel™ or any Microsoft Windows™ application program.

WinWedge is the software supplied for use with the ADM-870C and ADM-860C AirData
Multimeters.  Configuration files must be set up to specify how WinWedge will interact with the
AirData Multimeter (or with any other device).  A series of fully functional, example Configuration
Files is provided along with the software.

These example Configuration Files are extremely easy to use, and are provided so the most basic
set-ups will occur automatically.  These basic setups provide the user with a straight-forward
introduction to the available features of WinWedge.  The following pages will help you in getting
set up and started quickly.

Two sets of Configuration Files are included on the 3.5" floppy disk.  One set is designed to be
used with Microsoft Excel and the other to be used with Quattro Pro™.  It is easy to know which file
to use, because the name of the spreadsheet program is part of the Configuration File name.  A
set of macro files for use with HyperTerminal are also included on the floppy disk. 

All of the port settings, data input settings, output settings, function keys, mouse buttons and other
information required to use WinWedge with the AirData Multimeter have already been set up in
each of these Configuration Files.  They are ready to be used as soon as loaded.  These files may
also be copied repeatedly and each copy modif ied as required to suit the needs of  the user.

If you have problems using the Configuration Files, call Shortridge Instruments, Inc. at (480) 991-
6744.  If you have problems with WinWedge itself, please call TAL Technologies at (215) 763-
5096.

SET-UP CONNECTIONS AND OPEN THE APPLICATIONS
Load the WinWedge software onto the computer.

Copy the Configuration Files from the 3.5" floppy disk to the same folder as WinWedge.

Open the spreadsheet application first, then open the WinWedge window.

Move and/or size the two application windows so they are adjacent (or overlapping) and both are
visible on the screen.  This allows for easiest viewing of the applications and use of the mouse.

Click on File > Open in WinWedge to view the list of Configuration Files.  Configuration files must
be in the same folder as WinWedge or they will not be displayed.

Open either Configuration File WW_DOWNLOAD_ALL_FIELDS_EXCEL_N.SW3 (N is the version
number of the file) or Configuration File WW_DOWNLOAD_ALL_FIELDS_QUATTRO_N.SW3 by
double clicking the file name or by highlighting the file name and clicking on Open in the
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WinWedge menu bar.
Connect the serial cable barrel connector to the RS232 jack on the right side of the meter.  The
red dot on the connector aligns with the red rectangle on the lower part of the jack.

Connect the DB9 connector to a computer port, either COM1 (preferable) or COM2.  If COM1 is
not available on the computer being used, COM2 must be selected.  Click on Port > Settings in
WinWedge and change the port selection from COM1 to COM2.  Click on OK.

Click on Activate > Test Mode in WinWedge.  The displayed window will include a field for the
record number and a series of input fields.  WinWedge is now ready to communicate with the
meter.  (If you are using Configuration File WW_DOWNLOAD_ALL_FIELDS_EXCEL_N.SW3 or
Configuration File WW_DOWNLOAD_ALL_FIELDS_QUATTRO_N.SW3, this window also
includes a series of  mouse buttons on the left side.  Ignore these for now).

ACTIVATE > TEST MODE
Always activate WinWedge in Test Mode during the learning process or while modifying a
Configuration File.  Test Mode permits you to return to the WinWedge Main Menu and change
ports or edit the configuration parameters.  You can modify a Configuration File and observe the
effects as part of the learning process, then save the modified Configuration File using Save As....
If you activate WinWedge in Normal Mode, you cannot alter any parameters without quitting
WinWedge and starting over again. 

FUNCTION KEYS/HOT KEYS
The meter may be controlled from the function keys at the top of the computer keyboard.
Pressing a function key sends a command to the meter.  The meter recognizes the command and
responds by changing modes, taking a reading, or downloading stored readings from meter
memory to the computer.  The function keys specified below have already been set-up in the
Configuration Files and are ready to use.

F1 Key (ALT > F1 in Quattro Pro) Initiates a meter reading
F2 Key Changes mode to Differential Pressure
F3 Key Changes mode to Pitot Tube
F4 Key Changes mode to Absolute Pressure
F5 Key Changes mode to Temperature
F6 Key Changes mode to VelGrid
F7 Key Changes mode to Flow Hood
F8 Key Changes mode to AirFoil
F9 Key Toggles units between English and Metric 
F10 Key Toggles between Local/Standard (ADM-870C only)
F11 Key Initiates download from meter memory

The F1 key is not recommended for use as a Function or Hot Key in Quattro Pro as it is
controlled by Quattro Pro as a HELP key.

CURSOR CONTROL WITHIN THE SPREADSHEET
A meter reading will be downloaded to the spreadsheet beginning with the cell where the cursor
is located.  The cursor will remain in the same column and should automatically move to the next
row for each subsequent reading.  If it doesn’t,  the cursor option in the spreadsheet application
must be changed.  If using Microsoft Excel, click on Tools > Options > Edit and change the cursor
action following Enter to be Down.  If using QuattroPro, click on Tools > Settings > General and
change Move Cell Selector > Enter Key to Down.
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INDIVIDUAL READINGS CONTROLLED FROM COMPUTER KEYBOARD
This method allows the user to control the meter from the computer keyboard while taking
individual readings and entering them directly into the spreadsheet.  

Open the spreadsheet application, then open WinWedge.  

Open Configuration File WW_DOWNLOAD_ALL_FIELDS_EXCEL_N.SW3 or Configuration File
WW_DOWNLOAD_ALL_FIELDS_QUATTRO_N.SW3.  

Position the cursor in the cell on the spreadsheet where data entry should begin.  Select the
appropriate mode using one of the function keys.  For instance, for Differential Pressure Mode,
press F2.  The mode selected will be downloaded from the meter to the spreadsheet.  

Then press F1 if you are using Microsoft Excel or ALT > F1 if you are using Quattro Pro to take
a reading.  The meter will take a reading and automatically download the result to the
spreadsheet.

These files are designed to download every available field from the meter to the spreadsheet.  The
cells will contain the command letter, the measurement mode, the conditions related to the
measurement (local density, standard temperature, etc.), the value of the measurement, and the
units.  Each field is loaded into a single cell and the data is easily manipulated within the
spreadsheet.

The downloaded data will look similar to the following example.

R PITOT TUBE LOCAL DENS STD 70/F 1187 FP
R PITOT TUBE LOCAL DENS STD 70/F 1464 FP
R PITOT TUBE LOCAL DENS STD 70/F 1499 FP

DOWNLOAD READINGS FROM MEMORY USING COMPUTER KEYBOARD
This method allows the user to control the meter from the computer keyboard while downloading
multiple readings from meter memory into the spreadsheet.  The number of stored readings may
be any number up to 200.  

Disconnect the RS232 cable from the meter.  

Press SHIFT/CLEAR on the meter keypad, then select the desired measurement mode. 

Select either the STORE mode or the AUTO/STORE (ADM-870C only) mode.  Store as many
readings as desired.

Return to the computer and connect the meter to the RS232 cable (cable should still be connected
to the computer).  

Open the spreadsheet application, then open WinWedge.  

O p e n  t h e  a p p r o p r i a t e  C o n f i g u r a t i o n  F i l e  w h i c h  b e g i n s  w i t h
WW_DOWNLOAD_ALL_FIELDS_...sw3.  
Position the cursor in the cell on the spreadsheet where data entry should begin.  Press F11 on
the computer keyboard to download the entire contents of meter memory to the spreadsheet.
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An M will be downloaded from the meter to the spreadsheet, followed by information related to the
stored readings, then followed by the actual readings.  The first column will contain the reading
sequence number.  The second will contain the reading value.  The third column will contain the
units.  Each reading is downloaded from the meter into a separate cell as a numerical entry that
can be readily manipulated using the spreadsheet functions.

These files are designed to download every available field to the spreadsheet.  The download
from the meter to the spreadsheet using either of these Configuration Files will look similar to the
following example.

M
PITOT TUBE
LOCAL DENS

1 3353 FP
2 3349 FP
3 3335 FP
4 3318 FP

The readings will remain stored in the meter memory until the memory is cleared by disconnecting
the RS232 cable, then pressing the SHIFT key, followed by the CLEAR key.

ALTERNATIVE CONFIGURATION FILES FOR INDIVIDUAL READINGS
The user may need a spreadsheet format that contains only the actual measurement value without
any of the related information.  The following four Configuration Files download only actual
individual meter readings.  It is important to label the data columns, and include other related f ield
information when using these files.

WW_DOWNLOAD_VALUE_ONLY_WITH_PROBE_EXCEL_N.sw3 is designed for use with
a Microsoft Excel spreadsheet.  This file downloads flow and velocity measurements that are
taken using the TemProbe and may also be used for pressure and temperature
measurements.

WW_DOWNLOAD_VALUE_ONLY_WITHOUT_PROBE_EXCEL_N.sw3 is designed for use
with a Microsoft Excel spreadsheet.  This file downloads flow and velocity measurements that
are taken without using the TemProbe and may also be used for pressure measurements.

WW_DOWNLOAD_VALUE_ONLY_WITH_PROBE_QUATTRO_N.sw3  is used with a Quattro
Pro spreadsheet.   This file downloads flow and velocity measurements that are taken using
the  TemProbe and may also be used for pressure and temperature measurements.

WW_DOWNLOAD_VALUE_ONLY_WITHOUT_PROBE_QUATTRO_N.sw3 is used with a
Quattro Pro spreadsheet.  This file downloads flow and velocity measurements that are taken
without using the TemProbe and may also be used for pressure measurements.

All four files can be used for individual readings controlled from the computer keyboard.  Pressing
F1 in Microsoft Excel or ALT > F1 in Quattro Pro will download a single reading into the
spreadsheet cell that has cursor control.

Each reading is downloaded into a separate cell as a numerical entry that can be readily
manipulated using the spreadsheet functions.  The download to the spreadsheet using either of
these four Configuration Files is a single value which will look similar to the following example.
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CONTROL (MOUSE) BUTTONS, CURSOR CONTROL, AND FILE PATHS
The Configuration Files beginning  with WW_DOWNLOAD_ALL_FIELDS.....SW3 utilize mouse
buttons.  These are displayed on the left side of the WinWedge window which is displayed after
selecting Activate > Test Mode.  The mouse buttons  (Read, Diff Press, Pitotube, Abs Pres, Temp,
VelGrid, FlowHood, AirFoil, Download) may be used instead of the Function Keys.  For instance,
instead of pressing F1 in Microsoft Excel or ALT > F1 in Quattro Pro, the user may click on the
Read button.

However, using the mouse buttons will remove the mouse cursor from the spreadsheet, so it
cannot be used to point to the destination of the data.  When this occurs, the data will not
download from the meter into the spreadsheet.  This can be fixed by selecting Mode > Send
Keystrokes To in the WinWedge Setup window and entering the name of the spreadsheet
program.  Just entering the name of the spreadsheet (Microsoft Excel or Quattro Pro) into the first
field will work if the spreadsheet is also open.

WinWedge will open a closed spreadsheet after a reading is taken, if the complete file-path to the
spreadsheet program has been entered into the second field.

When either method of controlling the destination has been selected, the meter actions can be
controlled by clicking the mouse cursor on the mouse buttons, and WinWedge will know where
to place the data.  When changing applications, remember to reset the entries in the Mode > Send
Keystrokes To window.

MINIMIZING WINWEDGE
The WinWedge windows may be minimized so the spreadsheet can utilize the entire screen while
readings are being taken.  The WinWedge Set-Up window, which displays the main menu, will
appear on the Microsoft Windows Taskbar if it is minimized during use, and may be maximized
by clicking on the button.

However, if the activated WinWedge > Test Mode window is minimized, WinWedge may appear
to disappear entirely.  The program may only be visible as a small icon in the system tray at the
right of the Microsoft Windows Taskbar.  Right-click on the icon, then click on Open to maximize
WinWedge again.

AUTOMATIC REPEAT READINGS CONTROLLED BY WINWEDGE
The WinWedge software can be programmed to initiate automatic readings in a continuous series,
or at specified intervals up to 27 hours.  This option may be used with any of the Configuration
Files, but the automatic reading option must be added to the Configuration File by the user.
Modified files should be saved under a new name. 

The set-up procedure for automatic readings is discussed at length in the AirData Multimeter
Instruction Manuals under the section  titled AUTOMATIC REPEAT READINGS CONTROLLED
BY WINWEDGE.  This is Section 5.7.8 in the ADM-870C Instruction Manual and Section  5.5.8
in the ADM-860C Instruction Manual.

Do not take automatic readings using the meter keypad while the meter is connected to the
computer.  The data cannot be manipulated in the spreadsheet and the meter may lock up. 

ALTERNATIVE DOWNLOAD METHOD
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It is possible (but not recommended) to use the printer download methods while connected to a
computer and using the WinWedge application.  The printer download methods are discussed in
the AirData Multimeter Instruction Manuals under the sections titled DOWNLOAD INDIVIDUAL
READINGS TO PRINTER and DOWNLOAD READINGS IN MEMORY TO PRINTER.   These are
Sections 5.6.1 and 5.6.3 in the ADM-870C Instruction Manual and Sections  5.4.1 and 5.4.2 in the
ADM-860C Instruction Manual. 

This type of download is controlled using the meter keypad instead of the computer keyboard.
The resulting spreadsheet format will look very similar to the printed format.  However, the data
stream is downloaded through WinWedge as alphanumeric text and is all placed in the same field
on the spreadsheet.  The data in this field cannot be manipulated using the spreadsheet functions.

The meter is also more prone to locking up and experiencing other problems due to confusion
between commands issued using the computer keyboard and commands issued using the meter
keypad.  It is better to avoid this printer equivalent download method.

SOFTWARE REGISTRATION
Register the serial number of your WinWedge software to become eligible for free technical
support from the software manufacturer.  The contact information is:

TAL Technologies, Inc.
2101 Brandywine Street, Suite 102
Philadelphia, PA 19130 USA
Tel: (215) 496-0202 Fax: (215) 496-0322
www.taltech.com

More information on using WinWedge is available in the WinWedge User’s Manual and in the
AirData Multimeter Instruction Manual for your meter.


