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RS232 Download using HyperTerminal™

General Discussion

HyperTerminal is a data communications utility program that has been distributed with many
Microsoft Windows® operating systems, including Windows 95, Windows 98, Windows Me, Windows
2000, and W indows XP.  T he version of  HyperTe rmina l supplied with Windows is authorized for
personal use only, but HyperTerminal Private Edition for business use may be purchased online at

www .hilgraev e.com /htpe/order.h tml.  The Private Ed ition comes w ith unlimited phone support for 60

days  from date of purchase and unlim ited, free em ail and web suppo rt.  A HyperTe rminal users

discussion group is also hosted at the website.

  

HyperTerminal Private Edition allows a user to download readings stored in memory on an ADM-

870C or ADM -860C A irData Multime ter into a  HyperTe rmina l window and save the data as a

HyperTerminal file.  

The data may be printe d in text form at from th e HyperTerm inal window  or may be c opied in text

format from the HyperTerminal window into a word processing program.  The data may also be
copied  into a Microsoft Excel™ spreadsheet, and converted to numerical format using macros

supplied on the 3.5" floppy disk.  The data can then be manipulated to obtain totals, averages,
standard deviations, etc.

HyperTerminal Private Edition and WinW edge® are both valid options for importing data from the

ADM-870C and ADM-860 C AirData Multimete rs.  H yperTerminal Private Edition is $29.95 and
requires the purchase of a serial communications cable (CB-Serial1) for $50.00 from Shortridge

Instruments, Inc.  T he price for W inWedg e is $295.00 and inc ludes the serial cable.  
 

Advantages of WinWedge

WinW edge has several features that are not available in HyperTerminal.  WinWedge downloads the

data directly into the sp readsheet or word  process ing application .  HyperTerm inal requires ext ra
steps.

WinW edge offers flexibility in configurin g the ou tput format to autom atically gen erate th e spec ific

data format required for extensive reports.

WinW edge allows the user to control the download of individual readings from the meter using hot
keys  on the computer keyboard.  The WinWedge software can also be programmed to initiate
autom atic repeat readings in a continuous series or at specified intervals ranging from a few seconds

up to 27 hours.

Using HyperTerminal

The operation of the  HyperTerminal com munications u tility program may vary somewhat between
operating systems and between computers.  This procedure will work with most systems.  See

section Additional Setup May Be Required, if problems are encountered.

Store a series of readings with an ADM-870C or ADM-86 0C AirData Multimeter.  Connect the serial

cable  barrel connector to the RS232 jack on the right side of the meter.  The red dot on the
connector aligns with the red rectangle on the lower part of the jack.  Connect the DB9 connector
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to a computer port, either COM1 (preferable) or COM2.  If COM1 is not available on the computer
being used, COM2 must be selected.

Turn the comp uter on.  Select Start > Programs > Accessories > Communications > HyperTerminal.

(Windows 95/98 may show Hypertrm .exe).

A large window will appear, titled New Connection - HyperTerminal.  A small window is titled
Connection Description and displays New Connection.  Select any appropriate name for the new
connection file and any icon.  File name can be descriptive, such as Test, Flow1, TAB2, or ROOM3.
Select OK.

The HyperTerminal working window will now display the file name in the title bar, followed by

HyperTe rmina l.  A small window will appear requesting area code, ph one num ber, etc.  S kip all entry

fields except Connect using.  Select either “COM1” (or COM2) or “direct to COM1” (or “direct to

COM2").  Select OK.
  

A small window will appear titled COM1 Properties with a tab  for Port Settings.  Select the following

port settings.

Bits per second: 9600

Data bits       8

Parity None
Stop bits       1
Flow control None
Select OK.

This  blank file s etup can be s aved a s a tem plate an d saved under a new  name each  time it is

accessed.  The saved f ile will retain the port setup parameters and eliminate the need for reentering
the COM1 Properties > Port Settings for each  new  file generated.   It  is important to save the blank
template file under a new name before loading any data into the file.  Once data has been loaded

into a HyperTerminal file, it can not be d eleted. 

The HyperTerminal working window will now be ready to display the data received through the

comm unications port.
  

Press the STORE key on the meter keypad to display the average, sum, minimum or maximum

reading in the stored reading sequence, then press the MODE key once.  “PRINT MEM?” will be

displayed.  Press the READ key.  The readings in memory will be downloaded into the
HyperTe rmina l window.  Th e readings w ill remain  stored  in the meter mem ory until the  mem ory is
cleared by p ressing the SH IFT key, fo llow ed by the CLEAR key.

Select File > Print on the HyperTerminal window to print the downloaded readings.  The meter

outputs three colum ns:  reading  sequence num ber, measurem ent value, and units.   An example of

readings printed from memory is shown below:

VELGRID

LOCAL DENS

STD 70# F

01 1576 FP

02 1581 FP
03 1578 FP

Select  File > Save As to save the downloaded readings to a file which can be imported into Excel

or another spreadsheet application.
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Highlight specific cells, then se lect Edit > Copy to copy and then paste the highlighted readings into
a word proces sing program.  Select Edit > Select A ll, followed by Edit > Copy to copy all information

in the HyperTerminal window.

Select  File > Exit  to terminate the s ession.  

Additional Setup May Be Required
If the meter data fails to download properly, check all of the following settings.

Select File > Properties > Settings and confirm the following settings:

Function, Arrow, and CTRL keys act as: select  Terminal Keys
Backspace key sends: select CTRL+H

Emulation: select Auto detect

Telnet terminal ID: select ANSI

Back scroll buffer lines: set to 500

Select File > Properties > Settings > ASCII Setup and select as follows:

ASCII sending
Send line ends with line feeds: no check

Ech o typed characters  locally: no check
Line  dela y: zero milliseconds
Character delay: zero milliseconds

ASCII Receiving
Append line feeds to incoming line ends: no check

Force incoming data to 7-b it ASCII no check
Wra p lines th at exceed term inal width: check

Select  File > Properties > Settings > Advanced Window Settings (not available on all systems) and

select as follows :  
Use FIFO buffers: check

The order in which the setup windows are displayed and their appearance may differ from the

general description.  Some operating systems require that information on the location and area code
be entered prior to selecting COM1 (or COM2).  This information is not relevant, but must be entered

to continue. 

Some systems do not display the New Connection - HyperTerminal window when HyperTerminal

is first loaded.   The icons for existing saved files will be displayed instead.  Select an existing file,

then select File > New Connection.  A popup w indow will appear, as king if you want to disconnect.
Select YES and the  New Connection window will be displayed.

Pasting Readings Into a Word Processing Program
Open a word proces sing docum ent.  Select Edit > Paste  from within the document.  The data copied

from HyperTe rmina l onto the clipboard will be pasted into the document.  Manipulate the text as

necessary to create a report.  See the following example.

VELGRID

UNITS - FP

LOCAL DENS

STD   70ßF
01R   1314
02R   1092

Importing Readings into Excel
Readings may be copied an d pasted directly into a spreads heet application.  This data is  copied  in
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a text format and can not be manipulated using the spreadsheet functions.  There are several
methods for importing data into Excel and retaining the original numerical attributes of the data.

Importing Readings into Excel using the predefined Excel spreadsheet HYP_TES T_1.XLS

The data may be converted to a numerical format using the predefined spreadsheet

HYP_TES T_1.XLS .  This  spreadsheet is supplied on the 3.5" floppy disk that is included with either

the ADM-870C or ADM-860C AirData Multimeter. The spreadsheet contains a macro for
automatic ally converting text downloaded from  the AirData Mu ltimete r into HyperTerm inal into
numerical form at.  

Download the data from the m eter into HyperT erminal as  described  under Using Hype rTerm inal.
Open the spreadsheet file named HYP_TES T_1.XLS  on the floppy dis k.  This  spreadshee t file

contains sev eral examples of c opied data.  

Highlight specific cells in the HyperTerminal window, then select Edit > Copy to copy the highlighted
readings.  Select Edit > Paste  from within the spreadsheet to paste the readings into the Excel

spreadsheet.  See the following example.

VELGRID
UNITS - FP

LOCAL DENS

STD   70ßF
01R   1314
02R   1092

Press CTRL + H at the  same time.   T he m acro w ill strip the text attributes from th e data.  Each
reading will be converted to a numerical entry that can be readily manipulated using the

spreadsheet functions. See the following example.

VELGRID
UNITS

LOCAL DENS

70

1314
1092

All previous data may be deleted from the HYP_TES T_1.XLS  file and it may be saved as  a template

for future spreadsheets.  The CT RL + H mac ro will be saved w ithin the spreadshee t.

Converting Imported Readings in Excel using the Predefined Macro H YP_MAC RO_1.B AS
Data in any Excel spreadsheet may be converted to a numerical forma t using the  predefined  macro
HYP_M ACRO_1.BAS.  This macro file is supplied on the 3.5" floppy disk that is included with either

the ADM-870C or ADM-860C AirData Multimeter and may be imported into any existing Excel
spreadsheet 

Download the data from the meter into HyperTerminal as described under Using HyperT erminal.
Open or define the Excel spreads heet.   Select  Tools > Ma cro > Visual Basic Editor > File > Import

File.  Click on a:\HYP_M ACRO_1.BAS (the file  may be located elsewhere if it has been saved).  The
macro w ill be imported into the existing spread sheet.

Select File > Close and Return to Microsoft Excel to return to the spreads heet.  

Pressing CTRL + H at the same time will run the macro and strip the text attributes from a ny data
copied from HyperTerminal into Excel, con verting the data to num erical format.    
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The macro will be saved within the Excel spreadsheet when it is saved.

Importing Readings into Excel using the Excel Text Import Wizard 

Open Excel.  Select File > Open.  Select  Files of type > All Files.  Select the file path where the

HyperTerminal file was saved.  Select Open.  Excel will display a Text Import W izard that works in

three steps.

Step 1 of 3 - Define Original Data Type
For Original Data Type, select Delimited.  A representation of the data to be imported will be
displayed in a scrollable field at the bottom of th e window.  The line numbers for the data in the

HyperTerminal file are dis played on  the left s ide of th is field.  The HyperTerm inal file contains  extra
lines of inform ation at  the top  which  are unre lated to  the data.  The se lines  will not be impo rted if

Start import at row: is specified for a row be low the unnec essary text. Select Next.

Step 2 of 3  - Define Delim iters
For Delimiters , select Space.  Check the  box for Treat Consecutive Delimiters As One.  Vertical lines

will be displayed in the scrollable field at the bottom of the window.  These lines indicate where Excel

recognized the spa ce delimiters and w ill place the data into separate c olumns.  Se lect Next.

Step 3 of 3 - Select the Data Format

The data to be imported is displayed in three columns in the scrollable field at the bottom of the

window.  The first column is the reading sequence number, the second column is the actual reading
and the third column is the units for the reading.  Select each column individually (that column will
become  shaded) and s elect how the d ata in that column  is to be formatted  when it is imported .  

 If the General format is selected for all three columns, the reading sequence number and the units
will be downloaded as text and the readings will be downloaded as numbers.  Note that the degrees

symbol does not import correctly.  See the following example.

VELG RID

UNITS - FP

LOCAL DENS

STD 70ßßF

01R 1314

02R 1092

03R 920

04R 839

If Do Not Im port (skip) is selected for columns one and three, and General is selected for column
two, a single column of readings will be imported into the spreadsheet.  See the following example.

28.3

28.3

28.3

28.3

28.3

Select Finish.  The d ata w ill be imported into the Excel sp readsheet an d may be manipulated direct ly

or copied into another s preadsheet w ith a predefined report form at.


